win7\WIN10远程桌面连接--“出现身份验证错误。要求的函数不支持”解决方案

win7、win10系统远程桌面无法连接,报“发生身份验证错误。要求的函数不受支持”的错误:

win7\WIN10远程桌面连接--“出现身份验证错误。要求的函数不支持”解决方案 站长 第1张

方案一

win7安装一下这个补丁,然后再修改组策略.win10跳过安装补丁,

贴出

win7 64位:

http://download.windowsupdate.com/d/msdownload/update/software/secu/2018/05/windows6.1-kb4103718-x64_c051268978faef39e21863a95ea2452ecbc0936d.msu

win7 32位:

http://download.windowsupdate.com/d/msdownload/update/software/secu/2018/05/windows6.1-kb4103718-x86_1e4b61004905b531e1541f829799c2ca88c15a01.msu

安装好补丁后重启机器,

然后开始菜单->运行gpedit.msc 打开配置项:计算机配置>管理模板>系统>凭据分配>加密Oracle修正 选择启用并选择易受攻击,配置保存后即可解决问题。

win7\WIN10远程桌面连接--“出现身份验证错误。要求的函数不支持”解决方案 站长 第2张

微软给出解决方案:

https://support.microsoft.com/zh-cn/help/4093492/credssp-updates-for-cve-2018-0886-march-13-2018

2018 年 5 月 8 日

将默认设置从“易受攻击”更改为“缓解”的更新。

相关的 Microsoft 知识库编号已在 CVE-2018-0886 中列出。

方案二

发现没有CredSSP文件怎么办?

1 打开注册表:regedit

2 找到目录HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters,修改AllowEncryptionOracle的值为2。

注意:此方法不一定会成功。

方案三

控制面板->卸载程序->查看已安装的更新:

看到了最近的更新补丁KB:4开头的,把这个月更新的全部删掉,然后系统重启电脑,再尝试远程。本方法没尝试过,留个资料。

评论回复